Project

General

Profile

Activity

From 06/02/2017 to 07/01/2017

07/01/2017

06:43 PM Feature #14: Svideo core for first prototype
sadosp wrote:
> Maybe is time to think about implementing one external RGB -> composite/s-video converter, fit direc...
Stephen
05:31 PM Feature #14: Svideo core for first prototype
Maybe is time to think about implementing one external RGB -> composite/s-video converter, fit directly to VGA output... sadosp
05:05 PM Feature #14: Svideo core for first prototype
That works, kind of! Basic screen and star wars shields look the correct colours, but I have no red. Also very grainy... foft
12:59 PM Feature #14: Svideo core for first prototype
Writing an 'atari-style' implementation instead of going via RGB. Fixed saturation, simple phase shift for colour. foft
07:10 AM Feature #14: Svideo core for first prototype
Interesting...
http://atariage.com/forums/topic/29621-atari-video-circuits-experiment/
So fixed saturation (exc...
foft
03:59 PM Feature #53 (Closed): Add version number to settings
Add version number to settings foft

06/30/2017

11:30 PM Bug #52: Atari Control Picture
foft wrote:
> I checked an older core in case I introduced it with the antic timing changes for pbi. Was bad then, s...
Stephen
10:15 PM Bug #52: Atari Control Picture
I checked an older core in case I introduced it with the antic timing changes for pbi. Was bad then, so unrelated.
...
foft
10:10 PM Feature #14: Svideo core for first prototype
Added a poke 712,15 for comparison of max values. Interesting how the amplitude for basic 'blue' is so much higher ye... foft
09:54 PM Feature #14: Svideo core for first prototype
I mean see how the 'white' on ready already takes most of the range, without trying to increase it. foft
09:54 PM Feature #14: Svideo core for first prototype
Atari
!composite_atari_basic.png!
Eclaire
!composite_eclaire_basic.png!
We have a range of 0-1v on the DAC. 0...
foft
09:50 PM Feature #14: Svideo core for first prototype
Added traces of Atari basic from the scope, to see the voltage level differences.
Eclaire is driving my monitor, A...
foft

06/29/2017

11:30 PM Bug #52 (Closed): Atari Control Picture
CORE14, PAL & NTSC exhibit the same behaviour. When displaying the attached Atari Control Picture, the colour blocks... Stephen
08:59 PM Bug #49: CORE13 - NTSC/PAL switching
I think I've identified the problem. If the zpu happens to exit the menu at the end of an 'original' cycle the pbi lo... foft

06/27/2017

07:54 PM No news
No news, I've been ill but am almost better!
Is anyone still alive here?
On an unrelated note found this artic...
foft

06/23/2017

07:27 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
It's written in c. The Atari core is built with a DMA port and the ability to freeze the 6502. Outside that there is ... foft
04:31 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Okay, sounds great. So, is the system menu actually an Atari program or is it VHDL code?
917k

06/22/2017

09:12 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Yeah, that should work. You just described a multiplexor btw.
Got guests this weekend, so will do the plumbing nex...
foft

06/21/2017

11:30 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Mark,
It works great! Very Cool! Thank you for the test build. If we can add a toggle to the system menu and assig...
917k
08:56 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
I put up a build with your mapping as ansikbd.sof in the usual place. Let me know if it works as expected please. foft
09:44 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Thanks
11 is left alt
extended 11 is right alt - I use 1xx for extended xx.
I'll build a test core with your c...
foft
02:55 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Rethinking this, I'm not sure if we need to have a user-mappable keyboard at all as long as we have support for both ... 917k
02:37 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
TEST 917k
09:02 PM Bug #33: Wizard of Wor
I'm going to build a debug tool to make it easier to track these things down.
For now, a workaround. Use 2x turbo ...
foft

06/20/2017

12:06 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
I would say just use a text file, it's easier to create/edit. Also, The EclaireXL could have keys that have no equiva... 917k
07:51 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
its keyboard mapping from ATARI800WIN Emulator, see attached file ndary
07:41 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
What is an a8k file? Is there already a keyboard mapping file format we can use? foft
09:41 PM Feature #2: PBI support
Excellent! sadosp
07:08 PM Feature #2: PBI support
Hias tried out PBI on the v1.
Surprise: Turbo freezer didn't work! Mine works perfectly on v2...
He investiga...
foft
07:36 PM Feature #14: Svideo core for first prototype
Worth a read for some background: http://codeandlife.com/2012/10/09/composite-video-decoding-theory-and-practice/#mor... foft
07:12 PM Feature #51 (New): Debug port
I'm finding it hard to track down issues in some games/programs. Output debug information so I can look into the prob... foft

06/17/2017

08:17 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
i think reading a key-map file from the SD CART is a good idea, an a8k file? if the key-map file is corrupt or missin... ndary
05:08 AM Feature #11: Non-uk keyboard support (custom keyboard mapping)
foft wrote:
> Computer generated c code for TK2 is here: http://atariage.com/forums/topic/263044-developerstesting-r...
917k

06/15/2017

10:24 PM Bug #33: Wizard of Wor
Turbo freezer does not freeze it when its in 'frozen blocks' state but does otherwise. foft
10:21 PM Bug #33: Wizard of Wor
Tried a different version and I get the 'freeze with blocks' at the end of every level. Will have to see what happens... foft
09:30 PM Bug #33: Wizard of Wor
Well I tried many settings in Altirra and can't reproduce with a different hardware variant.
Things I found:
i) Rec...
foft

06/14/2017

08:54 PM Bug #33: Wizard of Wor
I see this too. Any luck tracking down the cause? I'm hoping @xxl or @xuel can help me here with their machine code w... foft
07:54 AM Bug #33: Wizard of Wor
I checked a car version on core 14, it started this behavior on the first level after killing monsters and an additio... 917k

06/13/2017

10:20 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
Computer generated c code for TK2 is here: http://atariage.com/forums/topic/263044-developerstesting-required-for-min... foft
08:24 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
foft wrote:
> I suggest multiple os roms with a key to toggle
Yeeha! Sound perfect option in my ears!
sadosp
06:45 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
Yeah we should absolutely save this setting too foft
06:44 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
I suggest multiple os roms with a key to toggle foft
12:24 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
I have catch my self many times to set the older Atari OS (memopad) as default on settings menu only for this reason!... sadosp
12:17 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
Is the same thing like someone put a simple switch to rom, to disable the Basic on original hardware.
Really I dont ...
sadosp
12:12 PM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
foft wrote:
> Basic on/off is an os thing, I don't want to patch the os in firmware.
>
> Yes we need to see how t...
sadosp
08:49 AM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
Basic on/off is an os thing, I don't want to patch the os in firmware.
Yes we need to see how to get usb keyboard ...
foft
06:12 AM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
I don't remember if in the past have ask from Mark to add a future within settings menu, as to be possible to disable... sadosp
06:03 AM Bug #50: CORE13 - Option on initial powerup does not disable BASIC
Stephen wrote:
> When initially turning on the Eclaire, holding F8 does not disable internal BASIC. However, once b...
sadosp
02:18 AM Bug #50 (New): CORE13 - Option on initial powerup does not disable BASIC
When initially turning on the Eclaire, holding F8 does not disable internal BASIC. However, once booted, if I hold F... Stephen
05:31 PM Bug #48: CORE13 - Veronica BASIC not working
foft wrote:
> So all tests work but veronica basic does not?
>
> I know a bit about veronica, I built a veronica ...
Stephen
08:51 AM Bug #48: CORE13 - Veronica BASIC not working
So all tests work but veronica basic does not?
I know a bit about veronica, I built a veronica clone for the ultim...
foft
02:40 AM Bug #48: CORE13 - Veronica BASIC not working
OK - I got the rotator demo working. However, I cannot get Veronica BASIC to load. It either hangs or says it canno... Stephen
02:25 AM Bug #48: CORE13 - Veronica BASIC not working
Guys - I am very sorry. I was not loading the BIOS first. Veronica is working properly. I tried to delete this, bu... Stephen
02:23 AM Bug #48: CORE13 - Veronica BASIC not working
VREGREAD passes both tests, VRAMTEST passes the 4 tests. Stephen
02:21 AM Bug #48: CORE13 - Veronica BASIC not working
Also, VREGREAD fails both tests, and VRAMTEST fails all 4 tests.
Stephen
02:14 AM Bug #48 (Closed): CORE13 - Veronica BASIC not working
I've tried various RAM and NTSC/PAL settings. When I run "detector.com" from the attached ATR, the screen flickers a... Stephen
11:16 AM Bug #49: CORE13 - NTSC/PAL switching
Yeah I've noticed this too. I think there is a lockup on exiting the menu in general. foft
02:17 AM Bug #49 (Closed): CORE13 - NTSC/PAL switching
I've noticed several times when I switch between PAL and NTSC, then do a "save and apply", when I exit, and exit the ... Stephen

06/12/2017

09:57 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> It should work with any decent USB supply. So I think we need to improve our end to handle this variat...
sadosp
09:37 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
These are all 'quality' usb supplies - well Apple anyway! foft
09:34 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
It should work with any decent USB supply. So I think we need to improve our end to handle this variation.
I check...
foft
09:23 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> I have power supplies who state 5V, but if I measure them they are not.
I know Mark, and this is t...
sadosp
09:09 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
ndary wrote:
> i have a meter, just need clear instruction what to do and where to check
>
> Nir
Prepare your ...
sadosp
09:03 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
I have power supplies who state 5V, but if I measure them they are not.
You can measure on the joystick ports - o...
foft
08:58 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
i have a meter, just need clear instruction what to do and where to check
Nir
ndary
08:50 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Same reading in the 1st board also?
What the other guys said about it? None have a multi meter to check the voltag...
sadosp
08:38 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
I mean tps63002.
I have a multimeter. It still reads 3.8V today after the regulator - and 5V on the input. I trust...
foft
08:36 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
I read it at the switch. I checked with 4 psus - checking each time on the regulated outputs that my scope was still ... foft
08:34 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Mark, I think is time to send you a digital multi-meter as a gift! ;-)
I have a question. You read the 5v directly...
sadosp
08:21 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
"It is specified that devices' configuration and low-power functions must operate down to 4.40 V at the hub port by U... foft
08:17 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
"The ATX power supply specification states the 5VUSB rail can be between +4.75V and +5.25V."
I guess we need a reg...
foft
07:59 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
OK, I restarted my scope software and now get the correct readings. So a bit of a mystery but I suspect a plain old b... foft
12:36 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Hi Mark.
I use my 4 digits digital multimeter to take readings. My analogue scope TEK2445, isn't usefull at all for ...
sadosp
07:29 AM Bug #47: CORE 13 - Paddle, Touchtablet issues
Ok, so assuming my scope is wrong for now. Its a usb one, I don't trust the absolute levels that much. What are you u... foft

06/11/2017

10:41 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Even a worthless psu rated at 5v @ 500mA who in reality supply with 5.26v, after the regulator read 3.333v sadosp
10:33 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
I use these two power adapters below..
[[https://m-service.prom.ua/p47863721-zaryadnoe-ustrojstvo-white.html]]
...
sadosp
10:14 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> Maybe my tools are just not calibrated properly.
I don't have touch tablet in my possession, but I ...
sadosp
10:14 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> Maybe my tools are just not calibrated properly.
I don't have touch tablet in my possession, but I ...
sadosp
10:12 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> Maybe my tools are just not calibrated properly.
I don't have touch tablet in my possession, but I ...
sadosp
10:11 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> Maybe my tools are just not calibrated properly.
I don't have touch tablet in my possession, but I ...
sadosp
09:04 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Maybe my tools are just not calibrated properly. Well anyway the touch tablet does not seem to work with a decent PSU... foft
08:59 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> Still this this should be checked, but think its a red herring. I get the same reading on my scope - a...
sadosp
08:52 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
OK, I found that if I connect the Eclaire to my laptop for power, it works. If I connect it to a PSU, it doesn't! The... foft
08:32 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Still this this should be checked, but think its a red herring. I get the same reading on my scope - and on the v1 an... foft
08:19 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Going to check this on my scope, I don't trust my multimeter... foft
07:53 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
The odd thing is I get 3.8V instead of 3.3V. I don't understand that at all, investigating... This would push the thr... foft
07:42 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
foft wrote:
> I checked the touch tablet, confirmed not working on the new board. Very odd since this worked on v1 a...
sadosp
07:39 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
I checked the touch tablet, confirmed not working on the new board. Very odd since this worked on v1 and paddles are ... foft
07:36 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
", then I will check the touch tablet" foft
07:36 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
Yeah I mixed them up.
We swapped joystick ports 0/1 and 2/3 on the silkscreen. I made the same changes in the core...
foft
07:30 PM Bug #47: CORE 13 - Paddle, Touchtablet issues
To one point I don't remember till which firmware version, these work well. Maybe Mark later confuse something in Cor... sadosp
05:47 PM Bug #47 (Closed): CORE 13 - Paddle, Touchtablet issues
Touch Tablet not working
Paddles buttons and Knobs are not correlate for the same Paddle
ndary
09:13 PM Bug #45: CORE10 - IDE2+ SDX not working
testing IDE2+ on an ULTIMATE 1MB does not behave correctly as well ndary
09:08 PM Bug #45: CORE10 - IDE2+ SDX not working
Does the IDE2+ work in those modes on a real system? I mean on a standard version of those upgrades, not one of these... foft
08:53 PM Bug #45: CORE10 - IDE2+ SDX not working
Stephen wrote:
> In CORE10, when I boot with the IDE2+ installed, the machine initially goes right into self test mo...
Stephen
05:44 PM Bug #45: CORE10 - IDE2+ SDX not working
Tested and working on core 13
Nir
ndary
08:48 PM Bug #25: F10 Hard Reset Ignore inserted cartridge (Core v7)
This is still on the list, but not yet in place... foft
05:45 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
Tested and working on Core 13, need other guys to test on MIO and BlackBox
Nir
ndary
12:11 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
More info from Simus:
$D800..$DDFF is a ROM, $DE00...$DFFF is a RAM.
MPD is kept low all the time when apropriated ...
foft
03:09 PM Bug #34 (Closed): Problem booting with Core 9
this happen on every core after flashing, to solve it i simply remove and put back the SD Card and it works ndary
03:07 PM Bug #44 (Closed): CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when...
Checked IDE2+ On core 13 and i works!
case closed
ndary
02:09 PM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
Even on v13 it goes straight to the cart emu menu. My turbo freezer goes straight to the cart emu menu on my 600xl th... foft
01:54 PM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
Found a bug I introduced here. When MPD_N is low I was also disabling the rest of the OS rom... Ooops! IDE2+ holds it... foft
03:07 PM Bug #46 (Closed): CORE 10 - VOICE BOX does not work with Eclaire board
solved in CORE 13 ndary
01:53 PM Bug #46: CORE 10 - VOICE BOX does not work with Eclaire board
I've wired this up in core 13, but I need to checking the timing is correct on the logic analyzer. foft
11:30 AM Bug #46: CORE 10 - VOICE BOX does not work with Eclaire board
Pin 12 of SIO connector is used only by ancient Atari's 400 and 800 as a 12v dc supply. On eclaire XL is unconnected.... sadosp
10:01 AM Bug #46: CORE 10 - VOICE BOX does not work with Eclaire board
I guess you mean pin11? I think you confirmedthis works, but is quiet?
The problem is I think that this uses sio c...
foft

06/10/2017

11:43 PM Document: Main Board Interface 1 & 2 Pin-outs - v3 prototype
sadosp
11:41 PM Interface Pinouts V3.0.png
sadosp
01:45 PM Bug #46 (Closed): CORE 10 - VOICE BOX does not work with Eclaire board
i tested my Voice Box on a real Atari and on the Eclaire board and on the Eclair it does not work!
to run the Voic...
ndary

06/09/2017

11:40 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
ndary wrote:
> can you confirm that you get to the MIO Menu?
>
> Nir
After dinner I will find a power supply f...
Stephen
09:45 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
can you confirm that you get to the MIO Menu?
Nir
ndary
09:38 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
ndary wrote:
> i found this document.. can it be missing voltage on the PBI port?
>
> the interface seems to work...
Stephen
08:23 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
IDEPlus info from Simius:
IDE+ detaches OS ROM between $D800 and $DFFF and plug his own memory there. I uses also $D...
foft
09:59 PM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
Though that logic should only get hit after it stabilises... Hmmm. Well registering it anyway (grasping at straws!!) foft
09:46 PM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
I think I know why it won't boot with v11.
MPD_N is combinatorial logic driven from the address - and I use it too...
foft
09:26 PM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
I am also confirming that with Core 11, the exlaire will not boot with IDE2+ Rev C. A video signal is generated as m... Stephen
07:10 AM Bug #44: CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Fr...
I see the cart emu thing, I had not tested that... I had it disabled. Interesting, will check the manual for when tha... foft
09:59 PM Feature #2: PBI support
Turn on data write to bus earlier, for things that snap it early (like IDE2+).
Register MPD_N before feeding to the...
foft
09:29 PM Bug #45 (Closed): CORE10 - IDE2+ SDX not working
In CORE10, when I boot with the IDE2+ installed, the machine initially goes right into self test mode. Pressing rese... Stephen

06/08/2017

11:22 PM Bug #44 (Closed): CORE 11 - Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when...
Just tested CORE 11 and there is Bug in PBI - EclaireXL will not boot with IDE2+ Is connected and when Turbo Freezer ... ndary
09:43 PM Bug #42: Core 8 - Mic level is low
I think on the final board we should add a passive low pass filter to the ADC inputs. Also are large resistor to pull... foft
10:18 AM Bug #42: Core 8 - Mic level is low
yes Panos, the noise is when SIO of the XC12 is connected ndary
09:39 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
SO in v10 RST_N was just floating... foft
09:38 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
Found an issue with RST_N. I had disconnected it in v10 (I forgot) because when I reset the freezer broke. Well I was... foft
09:01 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
I checked MPD...
If MPD and EXTSEL are used in conjunction that seems to work fine.
If just MPD is used to expo...
foft
08:34 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
There is 5V on pin 47 and pin 48.
I see it drives EXSEL and MPD. I thought I'm handling that case properly, but I...
foft
08:09 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
no it does not, i already tried it Panos
Nir
ndary
07:31 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed

Nir,
If you power on eclaireXL and go to Basic, after keep down the start key and simultaneously press and leave t...
sadosp
07:21 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
i found this document.. can it be missing voltage on the PBI port?
the interface seems to work on the Eclair, when...
ndary
06:45 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
no, i dont have a logic analyzer or the schematics...
let me see what info i can gather
ndary
06:34 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
Perhaps we can test it by poking/peeking regs from basic... foft
05:36 PM Bug #43: Core 10 - IDE2+ Menu does not show when powering the computer with START key pressed
Does the rest of it work, just not the menu?
Do you have a logic analyzer? I can outputs some signals on the gpio ...
foft
04:39 PM Bug #43 (Closed): Core 10 - IDE2+ Menu does not show when powering the computer with START key pr...
the PBI device i am testing is the IDE2+ external interface that plugs to the PBI port
when i reset the computer wit...
ndary
04:37 PM Convert SOF file to JIC and Flashing EclaireXL V2 PCB core.pdf
ndary

06/07/2017

10:46 PM Bug #41: Core 8 - the backgound music in Gene & LMS demos are not the same as on a real ATARI
Just trying gene.xex - any particular point that you hear the difference? I'll have to check my real Atari later - ni... foft
01:07 PM Bug #41: Core 8 - the backgound music in Gene & LMS demos are not the same as on a real ATARI
Interesting. Did the Atari you tested on have dual pokey?
v9 only changes pbi support, no pokey work.
foft
11:31 AM Bug #41: Core 8 - the backgound music in Gene & LMS demos are not the same as on a real ATARI
confirmed this bug also in CORE9 ndary
10:34 PM PBI support!
Core v10 is out for both v1 and v2/3
The turbo freezer works! Both of them!
foft
10:27 PM Feature #2: PBI support
Please now test some other devices - and let me know how you get on:-) I can't guarantee its safe but the fact the fr... foft
10:12 PM Feature #2: PBI support
Woohoo, freezer is working after reset - and ramdisk is working from freezer! foft
10:08 PM Bug #39 (Closed): Internal turbo freezer crashes on v9
foft
10:07 PM Bug #39: Internal turbo freezer crashes on v9
Fixed in v10 (being built)
Issue was down to interaction between pbi takeover when freezer has disabled atari. e.g...
foft
05:33 PM Bug #16 (Closed): Audio bug report for Altirra
Many thanks Nir foft
02:13 PM Bug #16: Audio bug report for Altirra
I Confirm that these Audio tests sound the same on a real Atari and on EclairXL board
Nir
ndary

06/06/2017

09:19 PM Feature #2: PBI support
I added output of internal reads to the bus. I also fixed some cases around writes.
Now the external turbo freezer...
foft
09:16 PM Bug #42: Core 8 - Mic level is low
Noise is there only when the SIO connector of XC12 is connected?
sadosp
09:15 PM Bug #42: Core 8 - Mic level is low
Yeah we need a digital filter for that, part of the reason I don't want to make it louder yet:-). I found it pretty l... foft
09:00 PM Bug #42: Core 8 - Mic level is low
yes i connected correctly... and the volume still low..
i also notices that when the X12 is connected but nothing ...
ndary
08:26 PM Bug #42: Core 8 - Mic level is low
I don't have any tapes! I've not tuned the volume but it seemed pretty loud to me... foft
08:07 PM Bug #42: Core 8 - Mic level is low
Have you connect these with right polarity? I mean ground to ground etc?
sadosp
07:40 PM Bug #42 (New): Core 8 - Mic level is low
I connect the 2 pin header of MIC3 from the top board to the Bottom board (next to the speaker output)
and placed on...
ndary
07:16 PM Bug #41 (New): Core 8 - the backgound music in Gene & LMS demos are not the same as on a real ATARI
i Am attaching two demos that are set to run on an PAL Atari with 576k or 1meg ram
in both the background music is n...
ndary
08:57 AM Feature #28 (Closed): XEX boot loader replacement
foft
08:00 AM Feature #28: XEX boot loader replacement
foft wrote:
> Replace XEX boot loader with a better one
Das Omen works fine. You do not need to replace the loa...
xxl
08:56 AM Bug #20 (Closed): Bugs in DAS OMEN Demo
foft
06:46 AM Bug #38: Numen crashes on v9
(i managed to flash core 9 successfully, and Numen work when the memory is set to 320k compyshop.
numben crashed whe...
ndary

06/05/2017

10:49 PM Bug #39: Internal turbo freezer crashes on v9
(sorry i confirm that turbo freezer does crash on v9, not in the turbo freezer menu, but after you exist TB Freezer t... ndary
10:43 PM Bug #39: Internal turbo freezer crashes on v9
(I managed to flash CORE 9 (.SOF) file and the compute rebooted,
and pressing DEL take me to the Freezer software, ...
ndary
08:12 PM Videos
Nir posted a couple of great videos, really great. I particularly enjoyed seeing the side2 streaming working.
http...
foft
03:23 PM Bug #34: Problem booting with Core 9
ndary wrote:
> i did with same result, can anyone else confirm that core 9 works on on his v2 board?
>
> Nir
J...
Stephen

06/04/2017

02:13 PM Feature #40: Add support for Interlace mode (in scaler)
Actually this works in 15KHz mode! Try it in 'RGB' mode on a CRT. Also I found it works in 'scandouble mode' too iirc... foft
01:54 PM Feature #40 (New): Add support for Interlace mode (in scaler)
attached is the Memopad 480i tool that simulate interlace mode on the ATARI 800XL,
ExclairXL does not emulate inter...
ndary
01:20 PM Bug #34: Problem booting with Core 9
Thanks for checking Nir. I guess it must be on the 'edge' and thus some boards work and not others. Its working well ... foft
12:45 PM Bug #34: Problem booting with Core 9
i did with same result, can anyone else confirm that core 9 works on on his v2 board?
Nir
ndary
09:22 AM Bug #34: Problem booting with Core 9
One thing to try, can you see if it's the same with a few different power supplies? foft

06/03/2017

09:58 PM Bug #39 (Closed): Internal turbo freezer crashes on v9
Pressing delete to activate internal turbo freezer crashes the core foft
09:57 PM Bug #38 (Closed): Numen crashes on v9
Look into why foft
09:57 PM Feature #37 (Closed): SD card insertion support
If an SD card is removed/inserted we should detect it and initialize fat. Should be no need to reboot. The detect lin... foft
08:44 PM Bug #5 (Closed): SIDE2 does not work
Great, thanks Roy. Will close this for now, please reopen if it breaks again! foft
08:41 PM Bug #5: SIDE2 does not work
foft wrote:
> In v8, uh oh! I don't think I changed anything before v8 that would fix this... I will have to get Roy...
RoyE
12:31 PM Bug #5: SIDE2 does not work
In v8, uh oh! I don't think I changed anything before v8 that would fix this... I will have to get RoyE to double che... foft
09:04 AM Bug #5: SIDE2 does not work
I Confirm that SIDE 2 cart work on core8, should we close this bug?
Nir
ndary
12:37 PM Support #29 (Closed): LED for SIO activity
Great, closing. I'll note on the wiki that we should have a header for this on the final board. foft
12:36 PM Bug #20: Bugs in DAS OMEN Demo
So is the one a basic on/off issue? foft
12:33 PM Feature #28: XEX boot loader replacement
Or a patched OS, where the BASIC is turned off by default (you need to press OPTION in order to have BASIC). This is ... jozsef
12:30 PM Feature #28: XEX boot loader replacement
I'm actually tempted to make the 'menu' less emulator like where possible. It is a hardware recreation and having a p... foft
12:29 PM Feature #28: XEX boot loader replacement
Remember we're not an emulator and I'm hesitant to add extra portb logic etc or logic to force hold down keys for cer... foft
12:28 PM Feature #28: XEX boot loader replacement
Do you mean in F11? I never use this one, but I think its ok to hold option if you need it isn't it? The USB keyboard... foft
09:48 AM Feature #28: XEX boot loader replacement
Mark,
i found that the existing XEX loader behave better then i originally reported,
the problem is that when y...
ndary
12:29 PM Bug #35: When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the Eclair...
In fact, stick(0) depends on the mouse's position. jozsef
12:26 PM Bug #35: When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the Eclair...
stick(0) = 8, strig(0) = 1 jozsef
12:25 PM Bug #35: When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the Eclair...
I agree I should change the firmware to still allow keyboard movement when the joystick is held on. foft
12:17 PM Bug #35: When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the Eclair...
The joystick buttons and directions must be released to move. I guess the mouse presses some direction when idle. Wha... foft
11:19 AM Bug #35: When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the Eclair...
I have confirm this behavior with Core7 (but strangely not always). More to this: I have SIO2SD attached to Eclaire, ... jozsef
09:31 AM Bug #35 (New): When connecting ST Mouse to any JOY PORT on the expantion port, navigation on the ...
I have connected an ST Mouse o the EclairXL joyport to try and load some software that use the ST mouse but when the ... ndary
12:27 PM Bug #33: Wizard of Wor
Thanks for checking more versions, always worthwhile. We need to work out what is going wrong, or if its just a game ... foft
11:07 AM Bug #33: Wizard of Wor
Tried it today running more versions of WoW with the same results.
Addition to the behavior I described, when the ga...
jozsef
12:23 PM Bug #36: Joystick is always emulated through the USB keyboard arrow keys
The keyboard is mapped to match the Atari _layout_. Sorry the arrow keys are in the same location as on the 800XL. i.... foft
10:48 AM Bug #36: Joystick is always emulated through the USB keyboard arrow keys
Its is not about the keyboard mapping...
if you connect just a USB keyboard (not one with built in mouse) and you ...
ndary
10:31 AM Bug #36 (Rejected): Joystick is always emulated through the USB keyboard arrow keys
Not a bug, the keyboard matches the Atari layout.
See the core manual.
There is a feature request for custom mapp...
foft
09:34 AM Bug #36 (Rejected): Joystick is always emulated through the USB keyboard arrow keys

I have connected only a USB keyboard (not mouse, or USB keyboard with built in mouse), and noticed when i try to ru...
ndary
12:23 PM Feature #21 (Closed): Mirax Force game crash
Closing, not a bug with the loader. Just need to hold option to disable basic as usual! foft
12:20 PM Feature #21: Mirax Force game crash
Its the same as the 800xl, portb disables basic and the os changes portb when holding option. Of course you can chang... foft
10:54 AM Feature #21: Mirax Force game crash
notice that if you hold the OPTION KEY (F8) before selecting the file, it load correctly,
thus i believe we need to ...
ndary
08:20 AM Bug #34: Problem booting with Core 9
Though thinking some more if you get 'no sync' then that is before all the new logic starts, so more likely the build... foft
07:31 AM Bug #34: Problem booting with Core 9
Its either board-board instability due to small timing differences or the new input pins I guess.
Can you check th...
foft
07:33 AM Bug #31: HDMI Audio generate high pitch noise (Core 8)
HDMI audio to me seems very broken... Even just the 'bubbling' boot sound comes out wrong in my opinion. foft
07:32 AM Bug #31: HDMI Audio generate high pitch noise (Core 8)
So you are saying it happens with v7? OK that rules out the adc then. foft

06/02/2017

12:49 AM Bug #34 (Closed): Problem booting with Core 9
upgraded successfully to core 9
but when powering on the board, the ExclairXL boot one out of six times..
when i...
ndary
12:29 AM Bug #31: HDMI Audio generate high pitch noise (Core 8)
it happens with CORE 8 & 9 as well ndary
07:12 AM Bug #31: HDMI Audio generate high pitch noise (Core 8)
Did it on core 7 btw? If so I guess its aliasing from the adc noise? I need a low pass filter on input to the HDMI co... foft
07:08 AM Bug #31: HDMI Audio generate high pitch noise (Core 8)
The HDMI audio has some issues, I have another bug to find this. foft
10:56 PM Bug #4 (Closed): Galaxian flickers on scrolling - when using real cartridge
Fixed in v9 foft
10:50 PM Feature #2: PBI support
First cut released as v9. Sure there are some bugs, try at your own risk! foft
10:25 PM Feature #2: PBI support
I took a look at the turbo freezer on signaltap, I can't see it even trying to pull refresh after a reset. So I guess... foft
10:10 PM Feature #2: PBI support
Synced gtia delays to end of original 6502 cycle time and now acid is passing again. foft
03:45 PM Feature #2: PBI support
Well that horrible dma clock patch led to a complete acid pass except for a gtia failure. I see in gtia I have colour... foft
03:38 PM Feature #2: PBI support
I've been squashing test failures related to moving the cpu clock later in the '6502 cycle' due to PBI. None of these... foft
10:49 PM Bug #25: F10 Hard Reset Ignore inserted cartridge (Core v7)
Bumped to v10... foft
10:10 PM Bug #25: F10 Hard Reset Ignore inserted cartridge (Core v7)
Arg, of course I turned off pbi/cart in turbo mode and on zpu accesses... Better change that too I guess otherwise I ... foft
09:42 PM Bug #25: F10 Hard Reset Ignore inserted cartridge (Core v7)
Added to svn code foft
10:49 PM Bug #27 (Closed): USB D-PAD Joystick support on CORE7
Decided to call pbiv28 v9... Closing as complete. foft
10:23 PM Bug #27: USB D-PAD Joystick support on CORE7
Confirmed good as of pbiv28.sof. This release is almost ready for v9.sof, but some issues to fix first... foft
09:29 PM Bug #27: USB D-PAD Joystick support on CORE7
Switched this to another output so it should no longer crash in next release foft
10:28 AM Bug #27: USB D-PAD Joystick support on CORE7
I checked the code and I'm using zpu_out5 for both joystick and video mode! foft
10:31 PM Feature #11: Non-uk keyboard support (custom keyboard mapping)
The mapping from ps2 to atari key code is here:
http://www.64kib.com/atarixlfpga_svn/trunk/atari_800xl/common/a8core...
admin
08:07 PM Bug #33: Wizard of Wor
If this is confirmed it will need some digging to get to the root cause. Anyone up for the challenge? foft
04:29 PM Bug #33 (Closed): Wizard of Wor
Loading it from an external sio2SD drive with core 7:
At least on the 4th of 5th level, the monsters start appearing...
jozsef
05:06 PM Support #29: LED for SIO activity
Connected to SIO-IN and 5V (SIO-IN is reversed). Works fine. Thank you. jozsef
09:54 AM Feature #32: option to connect the original ATARI XL keyboard to ExclairXL
I mean I have the pokey signals and can break them out. To use an XL one we'd need a board with a suitable socket and... foft
08:39 AM Feature #32: option to connect the original ATARI XL keyboard to ExclairXL
yes i did.. but i was hoping for a real XL keyboard.. not the mushy XE ones :) ndary
07:11 AM Feature #32: option to connect the original ATARI XL keyboard to ExclairXL
You've also seen I had an XEGS keyboard connector on the old board?
http://www.64kib.com/eclairexl.html
We have s...
foft

06/01/2017

01:33 AM Bug #18: Power on Switch
ndary wrote:
> in a REAL ATARI XL/XE computer you switch the computer on by flipping the POWER SWITCH UP, but in the...
Stephen
 

Also available in: Atom