Project

General

Profile

Feature #21

Mirax Force game crash

Added by ndary over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
05/30/2017
Due date:
% Done:

0%


Description

tested the MIRAX Force game

the Speech at the beginning of the game works. but the game will not start

can this be a bug in the XEX File loader?

Nir

$boot.bin (512 Bytes) ndary, 05/30/2017 11:33 PM

picodos.sys (4.83 KB) ndary, 05/30/2017 11:33 PM


Related issues

Related to Feature #28: XEX boot loader replacement Closed 05/31/2017

History

#1 Updated by foft over 4 years ago

Can you test it with aspeqt too?

#2 Updated by foft over 4 years ago

  • Assignee changed from foft to ndary

#3 Updated by ndary over 4 years ago

tested it ASPEQT and confirm that its a problem of the loader..
i used PICODOS from HIASOFT and most games/demos that does not load well with the EclairXL loader works now!!!

so its not a problem with the core but with the loader

#4 Updated by ndary over 4 years ago

  • Assignee changed from ndary to foft

ndary wrote:

tested it ASPEQT and confirm that its a problem of the loader..
i used PICODOS from HIASOFT and most games/demos that does not load well with the EclairXL loader works now!!!

so its not a problem with the core but with the loader

#5 Updated by foft over 4 years ago

ok, another loader issue.

Lets add a new task for changing the xex loader to picodos or another.

#6 Updated by xxl over 4 years ago

foft wrote:

ok, another loader issue.

Lets add a new task for changing the xex loader to picodos or another.

I can write proper loader.

#7 Updated by ndary over 4 years ago

#8 Updated by foft over 4 years ago

  • Related to Feature #28: XEX boot loader replacement added

#9 Updated by ndary over 4 years ago

  • Tracker changed from Bug to Feature

notice that if you hold the OPTION KEY (F8) before selecting the file, it load correctly,
thus i believe we need to add a feature in the settings to DISABLE BASIC ON/OFF

Nir

#10 Updated by foft over 4 years ago

Its the same as the 800xl, portb disables basic and the os changes portb when holding option. Of course you can change the os if you want the reverse.

#11 Updated by foft over 4 years ago

  • Status changed from New to Closed

Closing, not a bug with the loader. Just need to hold option to disable basic as usual!

Also available in: Atom PDF